use strict;
my $str = 'Th3 qu!ck br0wn f0x jumps 0v3r th3 l@zy d0g. ';
my $regex = qr/(?:\b|\d+)([a-z])|[\d+ +!.@]/p;
my $subst = '\\U\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";