import Foundation
let pattern = #"(?:\b|\d+)([a-z])|[\d+ +!.@]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Th3 qu!ck br0wn f0x jumps 0v3r th3 l@zy d0g. "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\U\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)