package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\b|\d+)([a-z])|[\d+ +!.@]`)
var str = `Th3 qu!ck br0wn f0x jumps 0v3r th3 l@zy d0g. `
var substitution = "\U\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}