const regex = /(?:\b|\d+)([a-z])|[\d+ +!.@]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b|\\d+)([a-z])|[\\d+ +!.@]', 'g')
const str = `Th3 qu!ck br0wn f0x jumps 0v3r th3 l@zy d0g. `;
const subst = `\U\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);