import re
regex = re.compile(r"(?:\b|\d+)([a-z])|[\d+ +!.@]")
test_str = "Th3 qu!ck br0wn f0x jumps 0v3r th3 l@zy d0g. "
subst = "\\U\\1"
result = regex.sub(subst, test_str)
if result:
print(result)