re = /(?:\b|\d+)([a-z])|[\d+ +!.@]/
str = 'Th3 qu!ck br0wn f0x jumps 0v3r th3 l@zy d0g. '
subst = '\\U\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result