import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\b|\\d+)([a-z])|[\\d+ +!.@]";
final String string = "Th3 qu!ck br0wn f0x jumps 0v3r th3 l@zy d0g. ";
final String subst = "\\U\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}