$re = '/(?:\b|\d+)([a-z])|[\d+ +!.@]/';
$str = 'Th3 qu!ck br0wn f0x jumps 0v3r th3 l@zy d0g. ';
$subst = "\U\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;