# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<\/?[a-z]+>\R(*SKIP)(*FAIL)|$/<br>/mg;t' <<< "<p>my text 1</p>
some other content
<p>some other paragraph followed by an html line break</p><br>
etc..."