import Foundation
let pattern = #"</?[a-z]+>\R(*SKIP)(*FAIL)|$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<p>my text 1</p>
some other content
<p>some other paragraph followed by an html line break</p><br>
etc...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<br>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)