# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"</?[a-z]+>\R(*SKIP)(*FAIL)|$"
test_str = ("<p>my text 1</p>\n"
"some other content\n"
"<p>some other paragraph followed by an html line break</p><br>\n"
"etc...")
subst = "<br>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.