#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)</?[a-z]+>\R(*SKIP)(*FAIL)|$"
Local $sString = "<p>my text 1</p>" & @CRLF & _
"some other content" & @CRLF & _
"<p>some other paragraph followed by an html line break</p><br>" & @CRLF & _
"etc..."
Local $sSubst = "<br>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)