package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)</?[a-z]+>\R(*SKIP)(*FAIL)|$`)
var str = `<p>my text 1</p>
some other content
<p>some other paragraph followed by an html line break</p><br>
etc...`
var substitution = "<br>"
fmt.Println(re.ReplaceAllString(str, substitution))
}