using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"</?[a-z]+>\R(*SKIP)(*FAIL)|$";
string substitution = @"<br>";
string input = @"<p>my text 1</p>
some other content
<p>some other paragraph followed by an html line break</p><br>
etc...";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}