const regex = new RegExp('</?[a-z]+>\\R(*SKIP)(*FAIL)|$', 'mg')
const str = `<p>my text 1</p>
some other content
<p>some other paragraph followed by an html line break</p><br>
etc...`;
const subst = `<br>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);