re = /<\/?[a-z]+>\R(*SKIP)(*FAIL)|$/m
str = '<p>my text 1</p>
some other content
<p>some other paragraph followed by an html line break</p><br>
etc...'
subst = '<br>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result