use strict;
my $str = '<p>my text 1</p>
some other content
<p>some other paragraph followed by an html line break</p><br>
etc...';
my $regex = qr~</?[a-z]+>\R(*SKIP)(*FAIL)|$~mp;
my $subst = '<br>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";