// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)</?[a-z]+>\R(*SKIP)(*FAIL)|$").unwrap();
let string = "<p>my text 1</p>
some other content
<p>some other paragraph followed by an html line break</p><br>
etc...";
let substitution = "<br>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}