import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "</?[a-z]+>\\R(*SKIP)(*FAIL)|$";
final String string = "<p>my text 1</p>\n"
+ "some other content\n"
+ "<p>some other paragraph followed by an html line break</p><br>\n"
+ "etc...";
final String subst = "<br>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}