$re = '~</?[a-z]+>\R(*SKIP)(*FAIL)|$~m';
$str = '<p>my text 1</p>
some other content
<p>some other paragraph followed by an html line break</p><br>
etc...';
$subst = "<br>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;