# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^ ]+)*.(\w{0,2}).([0-9]+)*.(.*.)/\1.S01E\3\4/;t' <<< "Yu.Yu.Hakusho Ep.001 - A Morte"