import Foundation
let pattern = #"([^ ]+)*.(\w{0,2}).([0-9]+)*.(.*.)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Yu.Yu.Hakusho Ep.001 - A Morte"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1.S01E\3\4"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}