using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^ ]+)*.(\w{0,2}).([0-9]+)*.(.*.)";
string substitution = @"\1.S01E\3\4";
string input = @"Yu.Yu.Hakusho Ep.001 - A Morte";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}