const regex = /([^ ]+)*.(\w{0,2}).([0-9]+)*.(.*.)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^ ]+)*.(\\w{0,2}).([0-9]+)*.(.*.)', '')
const str = `Yu.Yu.Hakusho Ep.001 - A Morte`;
const subst = `\1.S01E\3\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);