// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([^ ]+)*.(\w{0,2}).([0-9]+)*.(.*.)").unwrap();
let string = "Yu.Yu.Hakusho Ep.001 - A Morte";
let substitution = "\\1.S01E\\3\\4";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}