re = /([^ ]+)*.(\w{0,2}).([0-9]+)*.(.*.)/
str = 'Yu.Yu.Hakusho Ep.001 - A Morte'
subst = '\\1.S01E\\3\\4'
result = str.sub(re, subst)
# Print the result of the substitution
puts result