$re = '/([^ ]+)*.(\w{0,2}).([0-9]+)*.(.*.)/';
$str = 'Yu.Yu.Hakusho Ep.001 - A Morte';
$subst = "\1.S01E\3\4";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;