import re
regex = re.compile(r"([^ ]+)*.(\w{0,2}).([0-9]+)*.(.*.)")
test_str = "Yu.Yu.Hakusho Ep.001 - A Morte"
subst = "\\1.S01E\\3\\4"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)