package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^ ]+)*.(\w{0,2}).([0-9]+)*.(.*.)`)
var str = []byte(`Yu.Yu.Hakusho Ep.001 - A Morte`)
var substitution = []byte("\1.S01E\3\4")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}