#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([^ ]+)*.(\w{0,2}).([0-9]+)*.(.*.)"
Local $sString = "Yu.Yu.Hakusho Ep.001 - A Morte"
Local $sSubst = "\1.S01E\3\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)