using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(# .*)(&wego)";
string substitution = @"<a name=""$2""></a>\n$1 <a href=""/#$2""> βοΈ</a>";
string input = @"# Π¨ΠΌΡΠ³Π°ΡΠΎΠ» ΡΠ³ΠΎΠ³ΠΎ &wego
anch ""hi""
asldkjfasdkl # pookah
askdljf asdjk
asdkalfjasdlkfj
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}