import Foundation
let pattern = ##"(# .*)(&wego)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# Π¨ΠΌΡΠ³Π°ΡΠΎΠ» ΡΠ³ΠΎΠ³ΠΎ &wego
anch "hi"
asldkjfasdkl # pookah
askdljf asdjk
asdkalfjasdlkfj
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"<a name="$2"></a>\n$1 <a href="/#$2"> βοΈ</a>"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)