import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(# .*)(&wego)";
final String string = "# Π¨ΠΌΡΠ³Π°ΡΠΎΠ» ΡΠ³ΠΎΠ³ΠΎ &wego \n"
+ "anch \"hi\"\n"
+ "asldkjfasdkl # pookah\n"
+ "askdljf asdjk\n\n"
+ "asdkalfjasdlkfj\n";
final String subst = "<a name=\"$2\"></a>\\n$1 <a href=\"/#$2\"> βοΈ</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}