import re
regex = re.compile(r"(# .*)(&wego)", flags=re.MULTILINE)
test_str = ("# Π¨ΠΌΡΠ³Π°ΡΠΎΠ» ΡΠ³ΠΎΠ³ΠΎ &wego \n"
"anch \"hi\"\n"
"asldkjfasdkl # pookah\n"
"askdljf asdjk\n\n"
"asdkalfjasdlkfj\n")
subst = "<a name=\"$2\"></a>\\n$1 <a href=\"/#$2\"> βοΈ</a>"
result = regex.sub(subst, test_str)
if result:
print(result)