$re = '/(# .*)(&wego)/m';
$str = '# Π¨ΠΌΡΠ³Π°ΡΠΎΠ» ΡΠ³ΠΎΠ³ΠΎ &wego
anch "hi"
asldkjfasdkl # pookah
askdljf asdjk
asdkalfjasdlkfj
';
$subst = "<a name=\"$2\"></a>\n$1 <a href=\"/#$2\"> βοΈ</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;