re = /(# .*)(&wego)/m
str = '# Π¨ΠΌΡΠ³Π°ΡΠΎΠ» ΡΠ³ΠΎΠ³ΠΎ &wego
anch "hi"
asldkjfasdkl # pookah
askdljf asdjk
asdkalfjasdlkfj
'
subst = '<a name="$2"></a>\\n$1 <a href="/#$2"> βοΈ</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result