use strict;
my $str = '# Π¨ΠΌΡΠ³Π°ΡΠΎΠ» ΡΠ³ΠΎΠ³ΠΎ &wego
anch "hi"
asldkjfasdkl # pookah
askdljf asdjk
asdkalfjasdlkfj
';
my $regex = qr/(# .*)(&wego)/mp;
my $subst = '<a name="$2"></a>\\n$1 <a href="/#$2"> βοΈ</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";