// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(# .*)(&wego)").unwrap();
let string = "# Π¨ΠΌΡΠ³Π°ΡΠΎΠ» ΡΠ³ΠΎΠ³ΠΎ &wego
anch \"hi\"
asldkjfasdkl # pookah
askdljf asdjk
asdkalfjasdlkfj
";
let substitution = "<a name=\"$2\"></a>\\n$1 <a href=\"/#$2\"> βοΈ</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}