const regex = /(# .*)(&wego)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(# .*)(&wego)', 'gm')
const str = `# Π¨ΠΌΡΠ³Π°ΡΠΎΠ» ΡΠ³ΠΎΠ³ΠΎ &wego
anch "hi"
asldkjfasdkl # pookah
askdljf asdjk
asdkalfjasdlkfj
`;
const subst = `<a name="$2"></a>\n$1 <a href="/#$2"> βοΈ</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);