package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(# .*)(&wego)`)
var str = `# Π¨ΠΌΡΠ³Π°ΡΠΎΠ» ΡΠ³ΠΎΠ³ΠΎ &wego
anch "hi"
asldkjfasdkl # pookah
askdljf asdjk
asdkalfjasdlkfj
`
var substitution = "<a name="$2"></a>\n$1 <a href="/#$2"> βοΈ</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}