# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/https:\\/\\/gyazo.com\\/([0-9A-Za-z]{1,32})/https:\/\/i.gyazo.com\/$1.png/;t' <<< "https://gyazo.com/683fd0d45622162038ee0aed541c45e4"