use strict;
my $str = 'https://gyazo.com/683fd0d45622162038ee0aed541c45e4';
my $regex = qr/https:\/\/gyazo.com\/([0-9A-Za-z]{1,32})/p;
my $subst = 'https://i.gyazo.com/$1.png';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";