#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "https:\/\/gyazo.com\/([0-9A-Za-z]{1,32})"
Local $sString = "https://gyazo.com/683fd0d45622162038ee0aed541c45e4"
Local $sSubst = "https://i.gyazo.com/$1.png"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)