import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/gyazo.com\\/([0-9A-Za-z]{1,32})";
final String string = "https://gyazo.com/683fd0d45622162038ee0aed541c45e4";
final String subst = "https://i.gyazo.com/$1.png";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}