import re
regex = re.compile(r"https:\/\/gyazo.com\/([0-9A-Za-z]{1,32})")
test_str = "https://gyazo.com/683fd0d45622162038ee0aed541c45e4"
subst = "https://i.gyazo.com/$1.png"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)