// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https:\/\/gyazo.com\/([0-9A-Za-z]{1,32})").unwrap();
let string = "https://gyazo.com/683fd0d45622162038ee0aed541c45e4";
let substitution = "https://i.gyazo.com/$1.png";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}