re = /https:\/\/gyazo.com\/([0-9A-Za-z]{1,32})/
str = 'https://gyazo.com/683fd0d45622162038ee0aed541c45e4'
subst = 'https://i.gyazo.com/$1.png'
result = str.sub(re, subst)
# Print the result of the substitution
puts result