import Foundation
let pattern = #"https:\/\/gyazo.com\/([0-9A-Za-z]{1,32})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://gyazo.com/683fd0d45622162038ee0aed541c45e4"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"https://i.gyazo.com/$1.png"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}