using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/gyazo.com\/([0-9A-Za-z]{1,32})";
string substitution = @"https://i.gyazo.com/$1.png";
string input = @"https://gyazo.com/683fd0d45622162038ee0aed541c45e4";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}