const regex = /https:\/\/gyazo.com\/([0-9A-Za-z]{1,32})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/gyazo.com\\\/([0-9A-Za-z]{1,32})', '')
const str = `https://gyazo.com/683fd0d45622162038ee0aed541c45e4`;
const subst = `https://i.gyazo.com/$1.png`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);